程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA - 10497 Sweet Child Makes Trouble

UVA - 10497 Sweet Child Makes Trouble

編輯:C++入門知識

UVA - 10497 Sweet Child Makes Trouble


Children are always sweet but they can sometimesmake you feel bitter. In this problem, you will see how Tintin, a five year’sold boy, creates trouble for his parents. Tintin is a joyful boy and is alwaysbusy in doing something. But what he does is not always pleasant for hisparents. He likes most to play with household things like his father’swristwatch or his mother’s comb. After his playing he places it in some otherplace. Tintin is very intelligent and a boy with a very sharp memory. To makethings worse for his parents, he never returns the things he has taken forplaying to their original places.

Think about a morning when Tintin has managed to‘steal’ three household objects. Now, in how many ways he can place thosethings such that nothing is placed in their original place. Tintin does notlike to give his parents that much trouble. So, he does not leave anything in acompletely new place; he merely permutes the objects.

Input

There will be several test cases. Each will havea positive integer less than or equal to 800 indicating the number of thingsTintin has taken for playing. Each integer will be in a line by itself. The inputis terminated by a –1 (minus one) in a single line, which should not beprocessed.

Output

For each test case print an integer indicating inhow many ways Tintin can rearrange the things he has taken.

Sample Input

2
3
4
-1

SampleOutput

1
2
9
題意:放回不同位置的方案數
思路:簡單的錯排問題,高精度處理
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		final int maxn = 805;
		BigInteger f[] = new BigInteger[maxn];
		f[1] = BigInteger.ZERO;
		f[2] = BigInteger.ONE;
		for (int i = 3; i < maxn; i++)
			f[i] = (f[i-2].add(f[i-1])).multiply(BigInteger.valueOf(i-1));

		Scanner in = new Scanner(System.in);
		int n;
		while (true) {
			n = in.nextInt();
			if (n == -1)
				break;
			System.out.println(f[n]);
		}
	}
}


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved