程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 1423 Big Number

poj 1423 Big Number

編輯:C++入門知識

Big Number http://poj.org/problem?id=1423
Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 24637 Accepted: 7895

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

Source

Dhaka 2002 思路:log10(n!)=log10(1*2*3…*n)=log10(1)+log10(2)+…+log10(n)

方法一:用空間換時間,開個數組把結果存起來一部分!
#include"stdio.h"
#include"math.h"
#include"string.h"
#define N 8000000
double a[N];
void Inti()
{
	int i;
	a[0]=0;
	for(i=1;i



方法二: n! = sqrt(2*π*n) * ((n/e)^n) * (1 + 1/(12*n) + 1/(288*n*n) + O(1/n^3)) π = acos(-1) e = exp(1) 兩邊對10取對數
忽略log10(1 + 1/(12*n) + 1/(288*n*n) + O(1/n^3)) ≈ log10(1) = 0 得到公式
log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e)。

#include"stdio.h"
#include"math.h"
#include"string.h"
#define N 80000
int main()
{
int t,n,i;
double s,pi,e;
pi=acos(-1);
e=exp(1);
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
s=log10(sqrt(2*pi*n))+n*log10(n/e);
if(n==1)
s=1;
printf("%d\n",(int)ceil(s));
}
return 0;
}

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved