程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVa 10341 - Solve It

UVa 10341 - Solve It

編輯:C++入門知識


原題:
Solve the equation:
        p*e-x + q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.
Input
Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: p, q, r, s, t and u(where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.
Output
For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.
Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1
Sample Output
0.7071
No solution
0.7554


分析與總結:
非線性方程求根問題, LRJ《算法入門經典》p150有類似的問題。  要求的跟是0~1之間, 而且這個方程是單調遞減的,所以可以用二分來求根。


[cpp] 
/*
 * UVa: 10341 - Solve It
 * Time: 0.024s
 * Result: Accept
 * Author: D_Double
 *
 */ 
#include<iostream> 
#include<cstdio> 
#include<cmath> 
#define EPS (10e-8) 
using namespace std; 
 
double p,q,r,s,t,u; 
 
inline double fomula(double x){ 
    return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u; 

 
 
int main(){ 
    while(scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF){ 
     
        double left=0, right=1, mid; 
        bool flag=false; 
        if(fomula(left)*fomula(right) > 0){ 
            printf("No solution\n");  
            continue; 
        } 
        while(right-left > EPS){ 
            mid = (left+right)/2; 
            if(fomula(mid)*fomula(left) > 0) left=mid; 
            else right=mid; 
        } 
     
        printf("%.4f\n", mid); 
    }  
    return 0; 

 


作者:shuangde800

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved