程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVa 10057 - A mid-summer nights dream.

UVa 10057 - A mid-summer nights dream.

編輯:C++入門知識


原題:
This is year 2200AD. Science has progressed a lot in two hundred years. Two hundred years is mentioned here because this problem is being sent back to 2000AD with the help of time machine. Now it is possible to establish direct connection between man and computer CPU. People can watch other people’s dream on 3D displayer (That is the monitor today) as if they were watching a movie. One problem in this century is that people have become so dependent on computers that their analytical ability is approaching zero. Computers can now read problems and solve them automatically. But they can solve only difficult problems. There are no easy problems now. Our chief scientist is in great trouble as he has forgotten the number of his combination lock. For security reasons computers today cannot solve combination lock related problems. In a mid-summer night the scientist has a dream where he sees a lot of unsigned integer numbers flying around. He records them with the help of his computer, Then he has a clue that if the numbers are (X1, X2,   …  , Xn) he will have to find an integer number A (This A is the combination lock code) such that
            
             (|X1-A| + |X2-A| + … … + |Xn-A|) is minimum.
 
Input
Input will contain several blocks. Each block will start with a number n (0<n<=1000000) indicating how many numbers he saw in the dream. Next there will be n numbers. All the numbers will be less than 65536. The input will be terminated by end of file.
 
Output
For each set of input there will be one line of output. That line will contain the minimum possible value for A. Next it will contain how many numbers are there in the input that satisfy the property of A (The summation of absolute deviation from A is minimum). And finally you have to print how many possible different integer values are there for A (these values need not be present in the input). These numbers will be separated by single space.
 
Sample Input:
2
10
10
4
1
2
2
4

Sample Output:
10 2 1
2 2 1

分析與總結:
求出A,使得(|X1-A| + |X2-A| + … … + |Xn-A|)的值最小。
 那麼這個A其實就是中位數。那麼在排序之後,
如果數字個數為奇數,那麼中間那個就是唯一的中位數,如果是偶數,則會有中間的兩位數,而且在這兩位數之間的數也是。
再求數列中有幾個數時需要注意的是,奇數是求出中間兩個數之後,這兩個數的旁邊也可能會有相等的數

[cpp] 
/*
 * UVa: 10057 - A mid-summer night's dream.
 * Time: 0.236s
 * Result: Accept
 * Author: D_Double 
 * 
 */ 
#include<iostream> 
#include<cstdio> 
#include<algorithm> 
#define MAXN 1000010 
using namespace std; 
int arr[MAXN]; 
 
int main(){ 
    int n; 
    while(~scanf("%d",&n)){ 
        for(int i=0; i<n; ++i) 
            scanf("%d",&arr[i]); 
 
        sort(arr, arr+n); 
         
        int mid, left, right; 
        int ans_min, ans_num, ans_val; 
 
        if(n%2==0){ // 如果有偶數個數字 
            left=(n-2)/2;  right=(n)/2; 
             
            ans_min=arr[left]; 
             
            ans_num=0; 
            for(int i=left; arr[i]==arr[left]&&i>=0; --i) ++ans_num; 
            for(int i=right; arr[i]==arr[right]&&i<n; ++i) ++ans_num; 
             
            ans_val = arr[right]-arr[left]+1; 
        } 
        else{ 
            mid = (n-1)/2; 
 
            ans_min = arr[mid]; 
 
            ans_num=0; 
            for(int i=mid; arr[i]==arr[mid]&&i>=0; --i) ++ans_num; 
            for(int i=mid+1; arr[i]==arr[mid]&&i<n; ++i) ++ans_num; 
 
            ans_val = 1; 
        } 
        printf("%d %d %d\n", ans_min, ans_num, ans_val); 
    } 
    return 0; 


作者:shuangde800

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved