程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 2363 Blocks

POJ 2363 Blocks

編輯:C++入門知識

Description

Donald wishes to send a gift to his new nephew, Fooey. Donald is a bit of a traditionalist, so he has chosen to send a set of N classic baby blocks. Each block is a cube, 1 inch by 1 inch by 1 inch. Donald wants to stack the blocks together into a rectangular solid and wrap them all up in brown paper for shipping. How much brown paper does Donald need?
Input

The first line of input contains C, the number of test cases. For each case there is an additional line containing N, the number of blocks to be shipped. N does not exceed 1000.
Output

Your program should produce one line of output per case, giving the minimal area of paper (in square inches) needed to wrap the blocks when they are stacked together.
Sample Input

5
9
10
26
27
100
Sample Output

30
34
82
54
130
給定一個液體方塊N,可以任意變形(也是方塊),求最小表面積
設A*B*C==N,我們可以枚舉A={1........N};B={1..........N};C={1..........N};求出最小的值給ANS「N」;
用到ANS「N」時直接打印就可以了
LANGUAGE:C
CODE:
[html] 
#include<stdio.h> 
#define min(a,b) a<b?a:b 
#define INF 1<<30 
int ans[1001]; 
void getans() 

    int i,j,k; 
    for(i=1;i<1001;i++)ans[i]=INF; 
    for(i=1;i<1001;i++) 
    { 
        for(j=1;j<1001;j++) 
        { 
            if(i*j>1000)break; 
            for(k=1;k<1001;k++) 
            { 
                if(i*j*k>1001)break; 
                ans[i*j*k]=min(ans[i*j*k],(i*j+j*k+k*i)<<1); 
            } 
        } 
    } 

int main() 

    int n,cas; 
    getans(); 
    scanf("%d",&cas); 
    while(cas--) 
    { 
        scanf("%d",&n); 
        printf("%d\n",ans[n]); 
    } 
    return 0; 

 


作者:ultimater

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved