程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 4009 Transfer water(最小樹形圖)

HDU 4009 Transfer water(最小樹形圖)

編輯:C++入門知識

題目:
Transfer water
Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 2508    Accepted Submission(s): 934


Problem Description
XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.
 

Input
Multiple cases.
First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).
Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.
Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th household.
If n=X=Y=Z=0, the input ends, and no output for that.
 

Output
One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line.
 

Sample Input
2 10 20 30
1 3 2
2 4 1
1 2
2 1 2
0 0 0 0
 

Sample Output
30

Hint
In  3‐dimensional  space  Manhattan  distance  of  point  A  (x1,  y1,  z1)  and  B(x2,  y2,  z2)  is |x2‐x1|+|y2‐y1|+|z2‐z1|.
 
 

Source
The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest
 

Recommend
lcy
 


分析與總結:

最小樹形圖問題, 但是這題多了個自環的,也就是說可以是i點和他本身i也是可以連接的並且有一個權值。
這題的關鍵也在於解決這個問題。
一個方法是設置一個虛擬結點new,把所有的自環i都變成邊(new, i).
讓後便是以new為根結點,計算最小樹形圖了。

 

代碼:
[cpp]
#include<cstdio> 
#include<iostream> 
#include<cstring> 
#include<cmath> 
using namespace std; 
 
const int VN = 1005; 
const int INF = 0x7fffffff;  
 
template<typename Type> 
class Directed_MST{ 
public: 
    void init(int _n){ 
        n=_n+1; size=0; ans=0; 
    } 
    void insert(int u, int v, Type _w){ 
        E[size++].set(u,v,_w); 
    } 
    Type directed_mst(int root){ 
        while(true){ 
            for(int i=1; i<n; ++i)  
                in[i]=INF, id[i]=-1, vis[i]=-1; 
            for(int i=0; i<size; ++i){ 
                int u=E[i].u, v=E[i].v; 
                if(E[i].w < in[v] && u!=v){ 
                    pre[v] = u; 
                    in[v] = E[i].w;  
                } 
            } 
            in[root] = 0; 
            for(int i=1; i<n; ++i)if(i!=root){ 
                if(in[i]==INF) return -1; 
            } 
            int MXid = 1; 
            for(int i=1; i<n; ++i){ 
                ans += in[i]; 
                int v = i; 
                while(vis[v]!=i && id[v]==-1 && v!=root){ 
                    vis[v] = i; 
                    v = pre[v]; 
                } 
                if(v!=root && id[v]==-1){ 
                    for(int u=pre[v]; u!=v; u=pre[u]){ 
                        id[u] = MXid; 
                    } 
                    id[v] = MXid++; 
                } 
            } 
            if(MXid==1) break; 
            for(int i=1; i<n; ++i) 
                if(id[i]==-1) id[i] = MXid++; 
            for(int i=0; i<size; ++i){ 
                int u=E[i].u, v=E[i].v; 
                E[i].u = id[u]; 
                E[i].v = id[v]; 
                if(id[u] != id[v]) E[i].w -= in[v]; 
            } 
            n = MXid; 
            root = id[root]; 
        } 
        return ans; 
    } 
 
private: 
    struct Edge{ 
        int u,v; 
        Type w; 
        void set(int _u,int _v,Type _w){ 
            u=_u,v=_v,w=_w; 
        } 
    }E[VN*VN/2]; 
 
    Type ans;         // 所求答案 
    int n;            // 結點個數 
    int size;         // 邊的數量 
    int pre[VN];      // 權值最小的前驅邊 
    int id[VN];  
    int vis[VN];     // 是在環中還是在環外 
    Type in[VN]; 
}; 
 
Directed_MST<int>G; 
int X[VN],Y[VN],Z[VN]; 
int x,y,z; 
 
inline int Price(int i, int j){ 
    if(i==j) return Z[i]*x; 
    int mht = abs(X[i]-X[j])+abs(Y[i]-Y[j])+abs(Z[i]-Z[j]); 
    if(Z[i]>=Z[j]) return mht*y; 
    return mht*y+z; 

 
int main(){ 
    int n,m,k,u,v,w; 
    while(~scanf("%d%d%d%d",&n,&x,&y,&z)&&x+y+z){ 
        G.init(n+1); 
        for(int i=1; i<=n; ++i){ 
            scanf("%d%d%d",&X[i],&Y[i],&Z[i]); 
            G.insert(n+1, i, Z[i]*x); 
        } 
        for(int u=1; u<=n; ++u){ 
            scanf("%d",&k); 
            for(int j=1; j<=k; ++j){ 
                scanf("%d",&v); 
                if(u==v) continue; 
                G.insert(u,v,Price(u,v));  
            } 
        } 
        int ans = G.directed_mst(n+1); 
        if(ans<0) puts("poor XiaoA"); 
        else printf("%d\n",ans); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved