程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 廣度優先遍歷求解 ZOJ 649 (Rescue)

廣度優先遍歷求解 ZOJ 649 (Rescue)

編輯:C++入門知識

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.


Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."


Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output

13

 

 


廣度優先遍歷求解。 不同於一般的迷宮最短路徑求解,每步的時間是不確定的。因此需要用一個附加數據保存時間,並遍歷所有可達的情況。

那麼BFS是否會無限搜索下去呢?不會的,因為我們加入了判斷條件是,這種走法比之前所花費的時間更少。

 

 

[cpp]
#include <iostream>  
#include <queue>  
#include <stdio.h>  
using namespace std; 
#define MAXMN 200  
#define INF 1000000  
 
class Point{ 
    public: 
    int x,y,time; 
}; 
 
queue<Point> Q; 
int N,M; 
char map[MAXMN][MAXMN]; 
int mintime[MAXMN][MAXMN]; //表示到達當前位置所需要的 最短時間  
int dir[4][2] = { { -1, 0 }, { 0, -1 }, { 1, 0 }, { 0, 1 } }; 
int ax,ay; //結束位置  
 
int bfs(Point s){ //從s點開始搜索  
 
    Q.push(s); 
    Point hd; 
    while( !Q.empty()){ 
        hd = Q.front(); 
        Q.pop(); 
        for(int i=0; i<4; i++){ 
            int x = hd.x + dir[i][0]; 
            int y = hd.y + dir[i][1]; 
            if(x >= 0 && x <N && y >=0 && y < M && map[x][y] != '#'){ 
                Point t; 
                t.x = x; 
                t.y = y; 
                t.time = hd.time + 1; 
                if(map[x][y] == 'x') t.time ++; 
                if(t.time < mintime[x][y]){ 
                    mintime[x][y] = t.time; 
                    Q.push(t); 
                } 
            } 
        } 
    } 
    return mintime[ax][ay]; 

 
int main() { 
 
    while(scanf("%d %d", &N,&M) != EOF){ 
        for(int i=0; i<N; i++) 
            scanf("%s", map[i]); 
 
        int sx,sy; 
        Point start; 
        for(int i=0; i<N; i++){ 
            for(int j=0; j<M; j++){ 
                mintime[i][j] = INF; //mintime初始為最大,不可達  
                if(map[i][j] == 'a'){ 
                    ax = i; 
                    ay = j; 
                }else if(map[i][j] == 'r'){ 
                    sx = i; 
                    sy = j; 
                } 
            } 
        } 
 
        start.x = sx; 
        start.y = sy; 
        start.time = 0; 
        mintime[sx][sy] = 0; 
 
        int mint = bfs(start); 
        if(mint < INF) 
            printf("%d\n",mint); 
        else 
            printf("Poor ANGEL has to stay in the prison all his life.\n"); 
    } 
    return 0; 

#include <iostream>
#include <queue>
#include <stdio.h>
using namespace std;
#define MAXMN 200
#define INF 1000000

class Point{
 public:
 int x,y,time;
};

queue<Point> Q;
int N,M;
char map[MAXMN][MAXMN];
int mintime[MAXMN][MAXMN]; //表示到達當前位置所需要的 最短時間
int dir[4][2] = { { -1, 0 }, { 0, -1 }, { 1, 0 }, { 0, 1 } };
int ax,ay; //結束位置

int bfs(Point s){ //從s點開始搜索

 Q.push(s);
 Point hd;
 while( !Q.empty()){
  hd = Q.front();
  Q.pop();
  for(int i=0; i<4; i++){
   int x = hd.x + dir[i][0];
   int y = hd.y + dir[i][1];
   if(x >= 0 && x <N && y >=0 && y < M && map[x][y] != '#'){
    Point t;
    t.x = x;
    t.y = y;
    t.time = hd.time + 1;
    if(map[x][y] == 'x') t.time ++;
    if(t.time < mintime[x][y]){
     mintime[x][y] = t.time;
     Q.push(t);
    }
   }
  }
 }
 return mintime[ax][ay];
}

int main() {

 while(scanf("%d %d", &N,&M) != EOF){
  for(int i=0; i<N; i++)
   scanf("%s", map[i]);

  int sx,sy;
  Point start;
  for(int i=0; i<N; i++){
   for(int j=0; j<M; j++){
    mintime[i][j] = INF; //mintime初始為最大,不可達
    if(map[i][j] == 'a'){
     ax = i;
     ay = j;
    }else if(map[i][j] == 'r'){
     sx = i;
     sy = j;
    }
   }
  }

  start.x = sx;
  start.y = sy;
  start.time = 0;
  mintime[sx][sy] = 0;

  int mint = bfs(start);
  if(mint < INF)
   printf("%d\n",mint);
  else
   printf("Poor ANGEL has to stay in the prison all his life.\n");
 }
 return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved