程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU 4707 Pet(DFS(深度優先搜索)+BFS(廣度優先搜索))

HDU 4707 Pet(DFS(深度優先搜索)+BFS(廣度優先搜索))

編輯:C++入門知識

Pet Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 535 Accepted Submission(s): 258     Problem Description One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.   Input The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.   Output For each test case, outputin a single line the number of possible locations in the school the hamster may be found.   Sample Input 1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9   Sample Output 2   Source 2013 ACM/ICPC Asia Regional Online —— Warmup   DFS(深度優先搜索)

import java.io.*;  
import java.util.*;  
public class Main {  
    BufferedReader bu;  
    PrintWriter pw;  
    int MAX=1000001;  
    int t,n,d,e,num;  
      
    int head[]=new int[MAX];  
    Node node[]=new Node[MAX];  
    boolean boo[]=new boolean[MAX];  
      
    public static void main(String[] args) throws Exception{  
        new Main().work();  
    }  
    void work()throws Exception{  
        bu=new BufferedReader(new InputStreamReader(System.in));  
        pw=new PrintWriter(new OutputStreamWriter(System.out),true);  
          
        t=Integer.parseInt(bu.readLine());  
        while(t--!=0){  
            String str[];  
  
            str=bu.readLine().split(" ");  
            n=Integer.parseInt(str[0]);  
            d=Integer.parseInt(str[1]);  
            e=0;  
            num=1;  
            Arrays.fill(head, -1);  
            Arrays.fill(boo,false);  
              
              
            for(int i=1;i<n;i++){  
                str=bu.readLine().split(" ");  
                int a=Integer.parseInt(str[0]);  
                int b=Integer.parseInt(str[1]);  
                  
                add(a,b);  
                add(b,a);  
            }  
            boo[0]=true;  
            DFS(0,0);  
            pw.println(n-num);  
        }  
    }  
  
    void DFS(int x,int index){  
        if(index>=d)  
            return;  
        for(int i=head[x];i!=-1;i=node[i].next){  
            int v=node[i].v;  
            if(!boo[v]){  
                boo[v]=true;  
                num++;  
                DFS(v,index+1);  
            }  
        }  
    }  
      
      
    void add(int a,int b){  
        node[e]=new Node();  
        node[e].v=b;  
        node[e].next=head[a];  
        head[a]=e++;  
    }  
      
      
    class Node{  
        int v;  
        int next;  
    }  
}  

 

BFS(廣度優先搜索)
 

 
import java.io.*;  
import java.util.*;  
public class Main {  
    BufferedReader bu;  
    PrintWriter pw;  
    Queue<Integer> que;  
    int MAX=200010;  
    int t,n,d,e,num;  
      
    int[] head=new int[MAX];  
    boolean[] boo=new boolean[MAX];  
    Node[] node=new Node[MAX];  
    int dis[]=new int[MAX];  
    public static void main(String[] args) throws Exception{  
        new Main().work();  
    }  
    void work()throws Exception{  
        bu=new BufferedReader(new InputStreamReader(System.in));  
        pw=new PrintWriter(new OutputStreamWriter(System.out),true);  
        que=new LinkedList<Integer>();  
        t=Integer.parseInt(bu.readLine());  
        String str[];  
        while(t--!=0){  
            str=bu.readLine().split(" ");  
            n=Integer.parseInt(str[0]);  
            d=Integer.parseInt(str[1]);  
              
            Arrays.fill(head,-1);  
            Arrays.fill(boo, false);  
            Arrays.fill(dis,0);  
            que.clear();  
              
            e=0;  
            num=0;  
              
            for(int i=1;i<n;i++){  
                str=bu.readLine().split(" ");  
                int a=Integer.parseInt(str[0]);  
                int b=Integer.parseInt(str[1]);  
                add(a,b);  
                add(b,a);  
            }  
            boo[0]=true;  
            que.add(0);  
            BFS();  
            pw.println(num);  
        }  
    }  
    void BFS(){  
        while(!que.isEmpty()){  
            int t=que.poll();  
            for(int i=head[t];i!=-1;i=node[i].next){  
                int u=node[i].v;  
                if(!boo[u]){  
                    dis[u]=dis[t]+1;  
                    boo[u]=true;  
                    que.add(u);  
                }  
            }  
        }  
        for(int i=0;i<n;i++){  
            if(dis[i]>d&&boo[i])  
                num++;  
        }  
    }  
    void add(int a,int b){  
        node[e]=new Node();  
        node[e].v=b;  
        node[e].next=head[a];  
        head[a]=e++;  
    }  
    class Node{  
        int v;  
        int next;  
    }  
}  

 

 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved