程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU1088:Write a simple HTML Browser

HDU1088:Write a simple HTML Browser

編輯:C++入門知識

Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.


Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.


Output
You should display the the resulting text using this rules:
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  . If you read a <br> in the input, start a new line.
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.

 Sample Input
Hallo, dies ist eine
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines.
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung       mehrere Leerzeichen irritieren

Html genauso wenig wie

mehrere Leerzeilen.


Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei

produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.

 

題意:1.出現<br>換行

2.出現<hr>輸出‘-’

3.每一行的加上現在的單詞如果長度超過80則換行,每個單詞前留一個空格

4.結束時要輸出換行

解法:知道了題意之後,就是很簡單的題目了,注意處理就可以了

[cpp]
#include <stdio.h>  
#include <string.h>  
 
int main() 

    char s[10000]; 
    int len; 
    int cnt = 0; 
    while(~scanf("%s",s)) 
    { 
        if(!strcmp(s,"<br>")) 
        { 
            cnt = 0; 
            printf("\n"); 
        } 
        else if(!strcmp(s,"<hr>")) 
        { 
            if(cnt) 
            printf("\n--------------------------------------------------------------------------------\n"); 
            else 
            printf("--------------------------------------------------------------------------------\n"); 
            cnt = 0; 
        } 
        else 
        { 
            int len = strlen(s); 
            if(!cnt) 
            { 
                cnt = len; 
                printf("%s",s); 
            } 
            else if(cnt+len+1>80) 
            { 
                cnt=len; 
                printf("\n%s",s); 
            } 
            else 
            { 
                cnt+=len+1; 
                printf(" %s",s); 
            } 
        } 
    } 
    printf("\n"); 
 
    return 0; 

#include <stdio.h>
#include <string.h>

int main()
{
    char s[10000];
    int len;
    int cnt = 0;
    while(~scanf("%s",s))
    {
        if(!strcmp(s,"<br>"))
        {
            cnt = 0;
            printf("\n");
        }
        else if(!strcmp(s,"<hr>"))
        {
            if(cnt)
            printf("\n--------------------------------------------------------------------------------\n");
            else
            printf("--------------------------------------------------------------------------------\n");
            cnt = 0;
        }
        else
        {
            int len = strlen(s);
            if(!cnt)
            {
                cnt = len;
                printf("%s",s);
            }
            else if(cnt+len+1>80)
            {
                cnt=len;
                printf("\n%s",s);
            }
            else
            {
                cnt+=len+1;
                printf(" %s",s);
            }
        }
    }
    printf("\n");

    return 0;
}

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved