程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj3278 Catch That Cow

poj3278 Catch That Cow

編輯:C++入門知識

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36079   Accepted: 11123

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17Sample Output

4Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

完全是BFS,沒有什麼技巧,主要還是用VISIT標記,防重搜
 

 #include<iostream> 
#include<stdio.h> 
#include<cstring> 
using namespace std;  
struct tree{int x;int step;} queue[800050]; 
int visit[100050]; 
int n,k; 
int bfs() 
{ 
    int t,w,temp,minx=10000000,xx; 
    t=w=1; 
    queue[t].x=n; 
    visit[n]=1; 
    queue[t].step=0; 
    while(t<=w) 
    { 
     
         xx=queue[t].x; 
     
        if(xx>k) 
        { 
         
            temp=queue[t].step+xx-k;//如果比結果大,只能減,所以可以直接求出來! 
            if(temp<minx) 
                minx=temp; 
            t++;//這裡的T一定要加,要不然就錯了 
            continue; 
        } 
        if(xx*2<=100000&&(!visit[2*xx])) 
        { 
        queue[++w].x=xx*2; 
        visit[2*xx]=1;//用VISIT來標記,防止重搜 
        queue[w].step=queue[t].step+1; 
        if( queue[w].x==k) 
        { 
            if(queue[w].step<minx) 
                return queue[w].step; 
            else  
                return minx; 
        } 
        } 
        if(xx+1<=100000&&(!visit[xx+1])) 
        { 
        queue[++w].x=xx+1; 
        visit[xx+1]=1; 
        queue[w].step=queue[t].step+1; 
        if( queue[w].x==k) 
        { 
            if(queue[w].step<minx) 
                return queue[w].step; 
            else  
                return minx; 
        } 
        } 
        if(xx>=1&&(!visit[xx-1])) 
        { 
        queue[++w].x=xx-1; 
        visit[xx-1]=1; 
        queue[w].step=queue[t].step+1; 
        if( queue[w].x==k) 
        { 
            if(queue[w].step<minx) 
                return queue[w].step; 
            else  
                return minx; 
        } 
        } 
        t++; 
    } 
    return -1; 
} 
int main () 
{ 
    while(scanf("%d%d",&n,&k)!=EOF) 
    { 
        memset(visit,0,sizeof(visit)); 
        if(n>=k) 
            printf("%d\n",n-k); 
        else 
            printf("%d\n",bfs()); 
    } 
     
    return 0; 
} 

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
struct tree{int x;int step;} queue[800050];
int visit[100050];
int n,k;
int bfs()
{
 int t,w,temp,minx=10000000,xx;
 t=w=1;
 queue[t].x=n;
 visit[n]=1;
 queue[t].step=0;
 while(t<=w)
 {
 
   xx=queue[t].x;
 
  if(xx>k)
  {
  
   temp=queue[t].step+xx-k;//如果比結果大,只能減,所以可以直接求出來!
   if(temp<minx)
    minx=temp;
   t++;//這裡的T一定要加,要不然就錯了
   continue;
  }
  if(xx*2<=100000&&(!visit[2*xx]))
  {
  queue[++w].x=xx*2;
  visit[2*xx]=1;//用VISIT來標記,防止重搜
  queue[w].step=queue[t].step+1;
  if( queue[w].x==k)
  {
   if(queue[w].step<minx)
    return queue[w].step;
   else
    return minx;
  }
  }
  if(xx+1<=100000&&(!visit[xx+1]))
  {
  queue[++w].x=xx+1;
  visit[xx+1]=1;
  queue[w].step=queue[t].step+1;
  if( queue[w].x==k)
  {
   if(queue[w].step<minx)
    return queue[w].step;
   else
    return minx;
  }
  }
  if(xx>=1&&(!visit[xx-1]))
  {
  queue[++w].x=xx-1;
  visit[xx-1]=1;
  queue[w].step=queue[t].step+1;
  if( queue[w].x==k)
  {
   if(queue[w].step<minx)
    return queue[w].step;
   else
    return minx;
  }
  }
  t++;
 }
 return -1;
}
int main ()
{
 while(scanf("%d%d",&n,&k)!=EOF)
 {
  memset(visit,0,sizeof(visit));
  if(n>=k)
   printf("%d\n",n-k);
  else
   printf("%d\n",bfs());
 }
 
 return 0;
}
 

 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved