程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> HDU2192:MagicBuilding

HDU2192:MagicBuilding

編輯:C++入門知識

Problem Description
As the increase of population, the living space for people is becoming smaller and smaller. In MagicStar the problem is much worse. Dr. Mathematica is trying to save land by clustering buildings and then we call the set of buildings MagicBuilding. Now we can treat the buildings as a square of size d, and the height doesn't matter. Buildings of d1,d2,d3....dn can be clustered into one MagicBuilding if they satisfy di != dj(i != j).
Given a series of buildings size , you need to calculate the minimal numbers of MagicBuildings that can be made. Note that one building can also be considered as a MagicBuilding.
Suppose there are five buildings : 1, 2, 2, 3, 3. We make three MagicBuildings (1,3), (2,3), (2) .And we can also make two MagicBuilding :(1,2,3), (2,3). There is at least two MagicBuildings obviously.
 


Input
The first line of the input is a single number t, indicating the number of test cases.
Each test case starts by n (1≤n≤10^4) in a line indicating the number of buildings. Next n positive numbers (less than 2^31) will be the size of the buildings.
 


Output
For each test case , output a number perline, meaning the minimal number of the MagicBuilding that can be made.
 


Sample Input
2
1
2
5
1 2 2 3 3


Sample Output
1
2

直接輸出出現最多的次數即可

[cpp]  #include <stdio.h>  
#include <algorithm>  
using namespace std; 
 
int a[1000000]; 
 
int main() 

    int n; 
    scanf("%d",&n); 
    while(n--) 
    { 
        int m,i; 
        scanf("%d",&m); 
        for(i = 0;i<m;i++) 
        scanf("%d",&a[i]); 
        sort(a,a+m); 
        int l = 1,tem = a[0],max = 1; 
        for(i = 1;i<m;i++) 
        { 
            if(a[i] == tem) 
            { 
                l++; 
            } 
            else 
            { 
                tem = a[i]; 
                l = 1; 
            } 
            if(l > max) 
            max = l; 
        } 
        printf("%d\n",max); 
    } 
 
    return 0; 

#include <stdio.h>
#include <algorithm>
using namespace std;

int a[1000000];

int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m,i;
        scanf("%d",&m);
        for(i = 0;i<m;i++)
        scanf("%d",&a[i]);
        sort(a,a+m);
        int l = 1,tem = a[0],max = 1;
        for(i = 1;i<m;i++)
        {
            if(a[i] == tem)
            {
                l++;
            }
            else
            {
                tem = a[i];
                l = 1;
            }
            if(l > max)
            max = l;
        }
        printf("%d\n",max);
    }

    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved