程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 1160 - X-Plosives 即LA3644 並查集判斷是否存在環

UVA 1160 - X-Plosives 即LA3644 並查集判斷是否存在環

編輯:C++入門知識

X-Plosives

 

A secret service developed a new kind ofexplosive that attain its volatile property only when a specific association ofproducts occurs. Each product is a mix of two different simple compounds, towhich we call abinding pair. If N>2, thenmixing N different binding pairs containing N simple compounds creates apowerful explosive.For example, the bindingpairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive,while A+B, B+C, A+D (three pairs, four compounds) does not.

 

You are not a secret agent but only a guyin a delivery agency with one dangerous problem: receive binding pairs insequential order and place them in a cargo ship. However, you must avoidplacing in the same room an explosive association. So, after placing a set ofpairs, if you receive one pair that might produce an explosion with some of thepairs already in stock, you must refuse it, otherwise, you must accept it.

 

An example. Let’s assume you receive thefollowing sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the firstfour pairs but then refuse E+G since it would be possible to make the followingexplosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simplecompounds). Finally, you would accept the last pair, F+H.

 

Compute thenumber of refusals given a sequence of binding pairs.

 

Input

The input will contain several test cases, each of them as described below.Consecutive test cases are separated by a single blank line.
Instead of letters we will use integersto represent compounds. The input contains several lines. Each line(except the last) consists of two integers (each integer lies between 0 and 105)separated by a single space, representing a binding pair. The input ends in aline with the number –1. You may assume that no repeated binding pairsappears in the input.

 

Output

For each test case, a single line with the number ofrefusals.

 

Sample Input

1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

 

Sample Output

3

 

 

 

 


題意:   有一些簡單化合物   每個化合物由2中不同元素組成        然後按照順序依次將這些化合物放進車裡   但是如果車上存在k個簡單化合物 且正好包含k中元素的話

那麼他們將變成易爆的化合物   為安全起見     每當你拿到一個化合物的時候   如果它和已裝車的化合物形成易爆化合物   你就應當拒絕裝車  否則就應該裝車

請輸出有多少個化合物沒有裝車

 


思路:

注意題目要求k個簡單化合物 且正好包含k中元素   是任意k個化合物 也就是說 只要車裡存在任意k個化合物 如果他們含有元素也為k個 則不能裝入這樣的一個化合物

可以把每個元素看成頂點   一個化合物作為一條邊   當整個圖存在環的時候 組成環的邊對應的化合物就是危險的 否則是安全的

判斷是否會組成環 可以通過並查集  如果要添加的邊 x y同時在同一個集合中  那麼它將組成環  拒絕它  (參考劉汝佳 入門經典 )


[cpp]
#include<stdio.h>  
#include<string.h>  
const int size=100001; 
int parent[size],rank[size],count; 
void init() 

    int i; 
    for(i=0;i<size;i++) 
    { 
        parent[i]=i; 
        rank[i]=1; 
    } 
    count=0; 

int find(int n) 

    return n==parent[n]?n:parent[n]=find(parent[n]); 

void join(int a,int b) 

        if(rank[a]>rank[b]) 
        { 
            parent[b]=a; 
            rank[a]+=rank[b]; 
        } 
        else 
        {        
            parent[a]=b; 
            rank[b]+=rank[a]; 
        } 

int main() 

    int a,b; 
    init(); 
    while(scanf("%d",&a)!=EOF) 
    { 
        if(a==-1) 
        { 
             printf("%d\n",count);  init();  continue; 
        } 
        scanf("%d",&b); 
        a=find(a); 
        b=find(b); 
        if(a==b)  count++; 
        else join(a,b); 
    } 
    return 0; 

#include<stdio.h>
#include<string.h>
const int size=100001;
int parent[size],rank[size],count;
void init()
{
 int i;
 for(i=0;i<size;i++)
 {
  parent[i]=i;
  rank[i]=1;
 }
 count=0;
}
int find(int n)
{
 return n==parent[n]?n:parent[n]=find(parent[n]);
}
void join(int a,int b)
{
        if(rank[a]>rank[b])
  {
   parent[b]=a;
   rank[a]+=rank[b];
  }
  else
  {  
   parent[a]=b;
   rank[b]+=rank[a];
  }
}
int main()
{
 int a,b;
 init();
 while(scanf("%d",&a)!=EOF)
 {
  if(a==-1)
  {
             printf("%d\n",count);  init();  continue;
  }
  scanf("%d",&b);
        a=find(a);
  b=find(b);
  if(a==b)  count++;
  else join(a,b);
 }
 return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved