程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 10006 - Carmichael Numbers 數論(快速冪取模 + 篩法求素數)

UVA 10006 - Carmichael Numbers 數論(快速冪取模 + 篩法求素數)

編輯:C++入門知識

  Carmichael Numbers 

An important topic nowadays in computer science is cryptography. Some people even think that cryptography is the only important field in computer science, and that life would not matter at all without cryptography.  Alvaro is one of such persons, and is designing a set of cryptographic procedures for cooking paella. Some of the cryptographic algorithms he is implementing make use of big prime numbers. However, checking if a big number is prime is not so easy. An exhaustive approach can require the division of the number by all the prime numbers smaller or equal than its square root. For big numbers, the amount of time and storage needed for such operations would certainly ruin the paella.
However, some probabilistic tests exist that offer high confidence at low cost. One of them is the Fermat test.

Let a be a random number between 2 and n - 1 (being n the number whose primality we are testing). Then, n is probably prime if the following equation holds:

 

 

 

If a number passes the Fermat test several times then it is prime with a high probability.
Unfortunately, there are bad news. Some numbers that are not prime still pass the Fermat test with every number smaller than themselves. These numbers are called Carmichael numbers.

In this problem you are asked to write a program to test if a given number is a Carmichael number. Hopefully, the teams that fulfill the task will one day be able to taste a delicious portion of encrypted paella. As a side note, we need to mention that, according to Alvaro, the main advantage of encrypted paella over conventional paella is that nobody but you knows what you are eating.


Input
The input will consist of a series of lines, each containing a small positive number n ( 2 < n < 65000). A number n = 0 will mark the end of the input, and must not be processed.

Output
For each number in the input, you have to print if it is a Carmichael number or not, as shown in the sample output.

Sample Input
1729
17
561
1109
431
0

Sample Output
The number 1729 is a Carmichael number.
17 is normal.
The number 561 is a Carmichael number.
1109 is normal.
431 is normal.

題意:判斷一個數是不是Carmichael數。

如果一個數不是素數,且對於任意的2< a <n滿足方程 ,則稱n是Carmichael數;否則n就不是Carmichael數。

這個題的關鍵是求快速冪。

 

#include<stdio.h>
#include<string.h>
#include<math.h>
#define LL long long
int a[66000];
void judge_prime() /*篩法求素數*/
{
    int i,j,m=sqrt(65010+0.5);
    memset(a,0,sizeof(a));
    for(i=2;i<=m;i++)
    {
        if(!a[i])  /*素數為0*/
        {
            for(j=i*i;j<65010;j+=i)
                a[j]=1; /*非素數為1*/
        }
    }
}
LL pow_mod(LL a,LL n,LL m) /*遞歸求快速冪*/
{
    if(n==0) return 1;
    LL x=pow_mod(a,n/2,m);
    LL ans=x*x%m;
    if(n%2==1) ans=ans*a%m;
    return ans;
}
int main()
{
    judge_prime();
    LL i,n;
    bool flag;
    while(~scanf("%lld",&n)&&n)
    {
        if(!a[n])
        {
            printf("%lld is normal.\n",n);
            continue;
        }
        flag=true;
        for(i=2;i<n;i++)
        {
            if(pow_mod(i,n,n)!=i)
            {
                flag=false;
                break;
            }
        }
        if(flag)
            printf("The number %lld is a Carmichael number.\n",n);
        else
            printf("%lld is normal.\n",n);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved