程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> poj 1068 Parencodings (模擬)

poj 1068 Parencodings (模擬)

編輯:C++入門知識

Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17169   Accepted: 10296

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

 S  (((()()())))

 P-sequence     4 5 6666

 W-sequence     1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9Source

Tehran 2001
 
題意:
對於給出的原括號串,存在兩種數字密碼串:

1.p序列:當出現匹配括號對時,從該括號對的右括號開始往左數,直到最前面的左括號數,就是pi的值。

2.w序列:當出現匹配括號對時,包含在該括號對中的所有右括號數(包括該括號對),就是wi的值。


題目的要求:對給出的p數字串,求出對應的s串。串長均<=20.

提示:在處理括號序列時可以使用一個小技巧,把括號序列轉化為01序列,左0右1,處理時比較方便

 

代碼:

 

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

int p[30];
int w[30];
int s[100];

int main()
{
    int t,n,i,j,k,q;
    int sum1,sum2,head,rear,t1,t2,headw,rearw;
    scanf("%d",&t);
    while(t--)
    {
        sum1=0,sum2=0,head=0,rear=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&p[i]);
            if(sum1<p[i])
            {
                for(j=0;j<p[i]-sum1;j++)
                    s[rear++]=0;
                sum1=p[i];
            }
            s[rear++]=1;
            sum2++;
        }
        rearw=headw=0;
        while(head!=rear)
        {
            t1=0,t2=0;
            if(s[head]==1)
            {
                t1++;
                if(s[head-1]==0)
                    w[rearw++]=1;
                else
                {
                    t1++;
                    q=head-1;
                    while(t1!=t2)
                    {
                        q--;
                        if(s[q]==0)
                            t2++;
                        else
                            t1++;
                    }
                    w[rearw++]=t1;
                }
                head++;
            }
            else
                head++;
        }
        for(k=0;k<rearw;k++)
            printf("%d%c",w[k],k==rearw-1?'\n':' ');
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved