程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 3254 Corn Fields

POJ 3254 Corn Fields

編輯:C++入門知識

Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5221   Accepted: 2769

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input

2 3
1 1 1
0 1 0Sample Output

9Hint

Number the squares as follows:

1 2 3
  4 
There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
Source

USACO 2006 November Gold
 

   神奇的狀態壓縮dp

#include <iostream>   
#include <cstring>   
#include <cstdio>   
#define N 15   
#define M 1<<15   
#define mod 100000000   
using namespace std;  
int dp[N][M],sta[M],a[N],Top;  
int main()  
{  
    //freopen("data.in","r",stdin);   
    int n,m;  
    while(scanf("%d %d",&n,&m)!=EOF)  
    {  
        memset(a,0,sizeof(a));  
        for(int i=1;i<=n;i++)  
        {  
            for(int j=1;j<=m;j++)  
            {  
                int x;  
                scanf("%d",&x);  
                if(x==0)  
                {  
                    a[i]+=(1<<(m-j));  
                }  
            }  
        }  
        Top=0;  
        for(int i=0;i<(1<<(m));i++)  
        {  
            if(i&((i)<<1))  
            {  
                continue;  
            }  
            sta[Top++] = i;  
        }  
        memset(dp,0,sizeof(dp));  
        for(int i=0;i<=Top-1;i++)  
        {  
            if(sta[i]&a[1])  
            {  
                continue;  
            }  
            dp[1][i]++;  
        }  
        for(int i=2;i<=n;i++)  
        {  
            for(int j=0;j<=Top-1;j++)  
            {  
                if(sta[j]&a[i])  
                {  
                    continue;  
                }  
                for(int v=0;v<=Top-1;v++)  
                {  
                    if(sta[v]&a[i-1])  
                    {  
                        continue;  
                    }  
                    if(sta[v]&sta[j])  
                    {  
                        continue;  
                    }  
                    dp[i][j] = (dp[i][j]%mod + dp[i-1][v]%mod)%mod;  
                }  
            }  
        }  
        int res = 0;  
        for(int i=0;i<=Top-1;i++)  
        {  
            res=(res%mod+dp[n][i]%mod)%mod;  
        }  
        printf("%d\n",res);  
    }  
    return 0;  
}  

#include <iostream>
#include <cstring>
#include <cstdio>
#define N 15
#define M 1<<15
#define mod 100000000
using namespace std;
int dp[N][M],sta[M],a[N],Top;
int main()
{
    //freopen("data.in","r",stdin);
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                int x;
                scanf("%d",&x);
                if(x==0)
                {
                    a[i]+=(1<<(m-j));
                }
            }
        }
        Top=0;
        for(int i=0;i<(1<<(m));i++)
        {
            if(i&((i)<<1))
            {
                continue;
            }
            sta[Top++] = i;
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=Top-1;i++)
        {
            if(sta[i]&a[1])
            {
                continue;
            }
            dp[1][i]++;
        }
        for(int i=2;i<=n;i++)
        {
            for(int j=0;j<=Top-1;j++)
            {
                if(sta[j]&a[i])
                {
                    continue;
                }
                for(int v=0;v<=Top-1;v++)
                {
                    if(sta[v]&a[i-1])
                    {
                        continue;
                    }
                    if(sta[v]&sta[j])
                    {
                        continue;
                    }
                    dp[i][j] = (dp[i][j]%mod + dp[i-1][v]%mod)%mod;
                }
            }
        }
        int res = 0;
        for(int i=0;i<=Top-1;i++)
        {
            res=(res%mod+dp[n][i]%mod)%mod;
        }
        printf("%d\n",res);
    }
    return 0;
}


 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved