程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu 2955 Robberies (0 1背包)

hdu 2955 Robberies (0 1背包)

編輯:C++入門知識

Robberies
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8096 Accepted Submission(s): 3063

 

Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.


Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .


Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.


Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output
2
4
6

Source
IDI Open 2009


Recommend
gaojie


題意:給N個銀行,給出每個銀行裡相應的錢數bank[i].money和搶這個銀行被抓的概率pi。
            問在不被抓的情況下(被抓的概率小於給定值p時安全)能搶得的最大錢數。


分析:
1、搶n個銀行,不被抓,是每次都不被抓,用乘法原理處理每次不被抓的概率。
2、轉化為0 1 背包:將所有銀行的總錢數當做背包的容積v,將不被抓的概率當做cost[i],
      在一般的0 1背包中都是加上cost[i] ,這裡由於是乘法原理,所以應該是轉化為乘法。
      這樣,傳統的01背包累加問題變成了壘乘。
3、狀態轉移方程:dp[j]=max(dp[j],dp[j-bank[i].money]*bank[i].run)
    dp[j]表示搶j錢時的最大不被抓概率。

 


代碼:

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
struct node
{
    int money;
    double run;     //不被抓的概率
}bank[105];
double dp[105*105];   //數組的大小 開成105會RE

int main()
{
    double t,p;
    int T,i,n,j,maxmoney;
    scanf("%d",&T);
    while(T--)
    {
        maxmoney=0;
        scanf("%lf %d",&p,&n);
        p=1.0-p;           //最大被抓概率轉化為最小不被抓概率
        for(i=1;i<=n;i++)
        {
            scanf("%d %lf",&bank[i].money,&t);
            bank[i].run=1.0-t;           //轉化為不被抓的概率
            maxmoney+=bank[i].money;
        }
        memset(dp,0,sizeof(dp));       //初始化為0不是-1
        dp[0]=1.0;                   //不搶錢被抓概率為0
        for(i=1;i<=n;i++)         //搶i銀行的錢
        {
            for(j=maxmoney;j>=bank[i].money;j--)
                dp[j]=max(dp[j-bank[i].money]*bank[i].run,dp[j]);
        }
        for(i=maxmoney;i>=0;i--)      //從最大錢數開始枚舉
        {
            if(dp[i]>p)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}

/*
	for(i=1;i<=n;i++)
    {
		for(j=maxmoney;j>=bank[i].money;j--)
			dp[j]=max(dp[j-bank[i].money]*bank[i].run,dp[j]);
    }
	dp[j-bank[i].money]表示除了搶這個銀行,之前搶的銀行不被抓的概率。
	很類似組合數。
	結合第一個樣例:
	這樣依次算出的是dp[0](已知) dp[1] dp[3] dp[2] dp[6] dp[5] dp[4]

*/

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved