程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> zoj3329 One Person Game

zoj3329 One Person Game

編輯:C++入門知識

One Person Game

--------------------------------------------------------------------------------

Time Limit: 1 Second Memory Limit: 32768 KB Special Judge

--------------------------------------------------------------------------------

There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

Set the counter to 0 at first.
Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.
Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1
Sample Output

1.142857142857143
1.004651162790698
我們可以推出公式dp[i]=sum{pk*dp[i+k]}+p0*dp[0]+1,dp[i]表示當前分數是i是時的到游戲結束的期望,那麼dp[0],就是要求的,其實,我們可以發現一個歸律,求期望都是從後住前推的,比如,這裡,是由i+k推到i的,求概率的時候是剛好相反的,但我們發現求出的這個式子,是個環形的,所以要變形,因為,每一個都是和dp[0]相關的,我們可以設,dp[i]=a[i]*dp[0]+b[i],那麼dp[0]不就是,b[i]/(1-a[i])了麼,我們,把這個式子代入上式就可以得到,dp[i]=sum{pk*a[i+k]}+p0,b[i]=sum{pk*b[i+k]}+1,這樣,就可以馬上求結果來了!

#include <iostream>   #include <stdio.h>   #include <string.h>   using namespace std;  #define MAXN 550   double pa[MAXN],pb[MAXN],dp[MAXN],p[MAXN];  int main()  {      int tcase,i,j,k,n,a,b,c,k1,k2,k3;      double p0;      scanf("%d",&tcase);      while(tcase--)      {          scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);          p0=1.0/k1/k2/k3;          memset(pa,0,sizeof(pa));          memset(pb,0,sizeof(pb));          memset(dp,0,sizeof(dp));          memset(p,0,sizeof(p));          for(i=1;i<=k1;i++)              for(j=1;j<=k2;j++)                  for(k=1;k<=k3;k++)                  if(i!=a||j!=b||k!=c)//不同時相等                       p[i+j+k]+=p0;          int temp=k1+k2+k3;          for(i=n;i>=0;i--)          {              pa[i]=p0;              pb[i]=1;              for(k=1;k<=temp;k++)              {                  pa[i]+=pa[i+k]*p[k];                  pb[i]+=pb[i+k]*p[k];              }          }          printf("%.15f\n",pb[0]/(1.0-pa[0]));      }      return 0;  }  #include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define MAXN 550
double pa[MAXN],pb[MAXN],dp[MAXN],p[MAXN];
int main()
{
    int tcase,i,j,k,n,a,b,c,k1,k2,k3;
    double p0;
    scanf("%d",&tcase);
    while(tcase--)
    {
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
        p0=1.0/k1/k2/k3;
        memset(pa,0,sizeof(pa));
        memset(pb,0,sizeof(pb));
        memset(dp,0,sizeof(dp));
        memset(p,0,sizeof(p));
        for(i=1;i<=k1;i++)
            for(j=1;j<=k2;j++)
                for(k=1;k<=k3;k++)
                if(i!=a||j!=b||k!=c)//不同時相等
                    p[i+j+k]+=p0;
        int temp=k1+k2+k3;
        for(i=n;i>=0;i--)
        {
            pa[i]=p0;
            pb[i]=1;
            for(k=1;k<=temp;k++)
            {
                pa[i]+=pa[i+k]*p[k];
                pb[i]+=pb[i+k]*p[k];
            }
        }
        printf("%.15f\n",pb[0]/(1.0-pa[0]));
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved