程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 1015. Reversible Primes (20) PAT

1015. Reversible Primes (20) PAT

編輯:C++入門知識

題目的意思是:給出一個數N和一個基數D。首先這個數必須是素數。其次,將這個數(1)轉為D進制數(2)將這個D進制數反轉(3)將反轉後的數再轉為十進制數,這個十進制數依然是素數。 這樣我們就輸出“Yes”。

 


判斷素數:一個數N,如果從2到sqrt(N)都不存在因子,則認為這個數是素數。 注意:0和1不是素數。


將十進制數轉為n進制數:(待補充。。。)

 

 

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

 

#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;

bool is_Prime(int a)
{
	int i;
	if(a==0 || a==1) return false;

	//注意是i<=sqrt(),之前弄成i<sqrt,一直出錯
	for(i=2; i <= sqrt((double)a); i++){
		if( a%i == 0) return false;
	}

	return true;
}

int change(int n,int d){
	int a[100000];
	memset(a,0,sizeof(a));
	int total = 0;
	int j;
	int i;
	for(i=0; ; i++){
		a[i] = n%d;
		n /= d;
		if(n==0) break;
	}

	for(j=0; j<=i; j++)
	{
		total = total*d + a[j];
	}
/*也可以這樣寫
	do 
	{
		total = total*d + n%d;
		n/=d;
	} while (n != 0);
*/
	return total;
}

int main()
{
	int N,D;
	while(cin>>N){
		if( N<0 ) break;
		cin>>D;
	    if( is_Prime(N) && is_Prime( change(N,D) )){
			cout<<"Yes"<<endl;
		}
		else{
			cout<<"No"<<endl;
		}
	}
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved