程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 1008. Elevator (20)

1008. Elevator (20)

編輯:C++入門知識

簡單題。電梯上升要6s,下降要4s,每個stop停靠5s,相加就好。

 

 

時間限制
400 ms

內存限制
32000 kB

代碼長度限制
16000 B

判題程序
Standard
作者
CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41

 

#include<iostream>
using namespace std;

int main()
{
	int N;
	cin>>N;
	int now = 0,next = 0,total = 0;
	while(N--){
		cin>>next;
		if(next > now){
			total += (next - now) * 6 + 5;
		}		
		else
			total += (now - next) * 4 + 5;
		now = next;
	}
	cout<<total<<endl;
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved