程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> 1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)

編輯:C++入門知識

 

題目描述:

 


This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

 


參考代碼:

分析:給出倆個多項式的指數和系數,沒有給出基數,只要將指數相同的多項式進行系數相加即可。輸出時按照指數從高到低的順序輸出。

            最後輸出的結果原先是這樣輸出:            

[cpp] view plaincopyprint?printf(" %d% .1lf",i,input[i]);  

      printf(" %d% .1lf",i,input[i]);           但是會有一組數據不通過。後來改為如下:           [cpp] view plaincopyprint?cout<<fixed<<setprecision(1);  
cout<<" "<<i<<" "<<input[i];  

      cout<<fixed<<setprecision(1);
      cout<<" "<<i<<" "<<input[i];           就可以通過了。但是這兩種寫法差在哪裡呢?







 #include<iostream>   
#include<string.h>   
#include<cstdio>   
#include<iomanip>   
using namespace std;  
#define max 1000   
double input[max + 1];  
  
int main()  
{  
    int k,count;  
    int i,expo;  
    double coef;  
    cin>>k;  
    memset(input,0,sizeof(input));  
    for(i=0; i<k; i++)  
    {  
        cin>>expo>>coef;  
        input[expo] += coef;  
    }  
    cin>>k;  
    for(i=0; i<k; i++)  
    {  
        cin>>expo>>coef;  
        input[expo] += coef;  
    }  
  
    count = 0;  
    for(i=1000; i>=0; i--)  
        if(input[i] != 0) count++;  
  
    cout<<count;  
    for(i=1000; i>=0; i--)  
        if(input[i] != 0.0)  
        {  
            cout<<fixed<<setprecision(1);  
            cout<<" "<<i<<" "<<input[i];  
            //不知道為什麼用下面這一句輸出會有一組數據通不過,不能AC。   
            //printf(" %d% .1lf",i,input[i]);   
        }  
    cout<<endl;  
    return 0;  
}  

#include<iostream>
#include<string.h>
#include<cstdio>
#include<iomanip>
using namespace std;
#define max 1000
double input[max + 1];

int main()
{
	int k,count;
	int i,expo;
	double coef;
	cin>>k;
	memset(input,0,sizeof(input));
	for(i=0; i<k; i++)
	{
		cin>>expo>>coef;
		input[expo] += coef;
	}
	cin>>k;
	for(i=0; i<k; i++)
	{
		cin>>expo>>coef;
		input[expo] += coef;
	}

	count = 0;
	for(i=1000; i>=0; i--)
		if(input[i] != 0) count++;

	cout<<count;
	for(i=1000; i>=0; i--)
		if(input[i] != 0.0)
		{
			cout<<fixed<<setprecision(1);
			cout<<" "<<i<<" "<<input[i];
			//不知道為什麼用下面這一句輸出會有一組數據通不過,不能AC。
			//printf(" %d% .1lf",i,input[i]);
		}
	cout<<endl;
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved