程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> POJ 1125 Stockbroker Grapevine

POJ 1125 Stockbroker Grapevine

編輯:C++入門知識

Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23783   Accepted: 13067

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.


Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0Sample Output

3 2
3 10題意:有1條謠言,n個證券經理,每個經理可以向其他人轉播謠言,(每個經理的傳播數任意)。而每個經理和其他經理傳播時,需要時間(如a對b傳播需要3,a對c傳播需要4)。問從哪個經理作為起點,能夠傳播的人數最多,並且時間最短。

 


其實這道題比較像是多點對之間的最短路,(首先要滿足傳播的人數最多,其次要滿足在所有最短路當中的最大值最小。。好繞口)

那我采用了Floyd來算多源最短路,之後再找到起點和最短時間

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define maxn 105
#define INF 1000000
using namespace std;
int n,map[maxn][maxn];
void init()
{
    int i,j;
    for (i=1; i<=n; i++)
    {
        for (j=1; j<=n; j++)
            map[i][j]=INF;
        map[i][i]=0;
    }
    for (i=1; i<=n; i++)
    {
        int t,a,b;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d",&a,&b);
            map[i][a]=b;
        }
    }
}
void floyd()
{
    int i,j,k;
    for (k=1; k<=n; k++)
        for (i=1; i<=n; i++)
            for (j=1; j<=n; j++)
                if (map[i][k]+map[k][j]<map[i][j])
                    map[i][j]=map[i][k]+map[k][j];
    k=0;
    int m=0,z=INF;
    /*
    for (i=1; i<=n; i++){
        for (j=1; j<=n; j++)
            cout<<map[i][j]<<" ";
        cout<<endl;
    }
    */
    for(i=1; i<=n; i++)
    {
        int p=0,t=0;
        for (j=1; j<=n; j++)
            if (map[i][j]!=INF)
            {
                if (map[i][j]>t) t=map[i][j];//用t來記錄以每個經紀人為起點,傳播的最長時間
                p++;//p來記錄每個經紀人可以傳多少其他人
            }
        if (p>m)//人數是第一個條件,所以人數大,就進行交換
        {
            m=p;
            k=i;
            z=t;
        }
        else if (p==m && t<z)//如果人數相同,就比較最長時間,取較短的
        {
            m=p;
            k=i;
            z=t;

        }
    }
    cout<<k<<" "<<z<<endl;
}
int main ()
{
    while(cin>>n)
    {
        if (n==0) break;
        init();
        floyd();
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved