程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> 問題一百二十七:Keep on Truckin

問題一百二十七:Keep on Truckin

編輯:關於C語言

Description

Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We're not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?


Input


Input to this problem will consist of multiple data sets. Each data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

The data sets end with a negetive integer.


Output

There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the smallest underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).
The height of the 18-wheeler is 168 inches.

Sample Input


180 160 170
-1
Sample Output


CRASH 160
 [plain] 
#include <stdio.h> 
  int main()  {   
  int i;   
  int j; 
    int t;  
   int flag;   
  int num[3];    
   while(scanf("%d", &num[0])!=EOF && num[0]>=0)  
   {            scanf("%d %d", &num[1], &num[2]);  
                     flag=0;        
     for(i=0; i<2; i++)        

   {               for(j=i+1; j<3; j++) 
              {               
   if(num[i]>num[j])            
      {                      t= num[i];    
                 num[i]= num[j];      
               num[j]= t;            
      }               }        
   }              for(i=0; i<3; i++)   
        {                if(num[i]<=168)   
            {                    flag=1;  
                 break;         
      }   
        }              if(flag)   
        {               printf("CRASH %d\n", num[i]);  
         }            else    
       {                printf("NO CRASH\n");   
        }      }            return 0;  }  #include <stdio.h>

int main()
{
    int i;
 int j;
 int t;
 int flag;
 int num[3];

 while(scanf("%d", &num[0])!=EOF && num[0]>=0)
 {
       scanf("%d %d", &num[1], &num[2]);
         
    flag=0;

    for(i=0; i<2; i++)
    {
       for(j=i+1; j<3; j++)
    {
        if(num[i]>num[j])
     {
        t= num[i];
     num[i]= num[j];
     num[j]= t;
     }
    }
    }

    for(i=0; i<3; i++)
    {
        if(num[i]<=168)
     {
         flag=1;
      break;
     }
    }

    if(flag)
    {
       printf("CRASH %d\n", num[i]);
    }
    else
    {
        printf("NO CRASH\n");
    }
 }
   
    return 0;
}   

 


\

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved