程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> 關於C語言 >> 問題一百二十八:IBM Minus One

問題一百二十八:IBM Minus One

編輯:關於C語言

You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.


Input

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output

For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

Print a blank line after each test case.

Sample Input


2
HAL
SWERC
Sample Output


String #1
IBM

String #2
TXFSD

 [plain]
 #include <stdio.h>
 #include <string.h>
    int main()  {    
  int  length;   
   int  num;    
  int i;     
 int  count=1;  
    char array[51]; 
       scanf("%d", &num); 
     getchar();      
  while(num--)       {                gets(array);    
            length=strlen(array);       
    for(i=0; i<length; i++)       
    {                if(array[i]>='A' && array[i]<'Z') 
              {                    array[i]+=1;    
           }                else if(array[i]=='Z')   
            {                    array[i]='A';     
          }            }          
 printf("String #%d\n", count++);   
          for(i=0; i<length; i++)           
{                printf("%c", array[i]);   
                  }                       
    printf("\n\n");                   }     
   return 0;  }   #include <stdio.h>
#include <string.h>

int main()
{
     int  length;
     int  num;
     int i;
     int  count=1;
     char array[51];

     scanf("%d", &num);
     getchar();

     while(num--)
     {   
          gets(array);
  
          length=strlen(array);
          for(i=0; i<length; i++)
          {
              if(array[i]>='A' && array[i]<'Z')
              {
                  array[i]+=1;
              }
              else if(array[i]=='Z')
              {
                  array[i]='A';
              }
          }
          printf("String #%d\n", count++);

          for(i=0; i<length; i++)
          {
              printf("%c", array[i]);         
          }
         
              printf("\n\n");
         
     }

     return 0;
}
  


\ 
(該題輸出有點問題,即輸出都空行)

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved