程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> [poj 2653] Pick-up sticks 線段相交

[poj 2653] Pick-up sticks 線段相交

編輯:C++入門知識

Pick-up sticks
Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 5   Accepted Submission(s) : 5

Problem Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
 

Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
 

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.


Sample Input
5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0
 

Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.
 

Source
PKU

[cpp] 
// 12-8-21.cpp : 定義控制台應用程序的入口點。 
// 
 
#include "stdafx.h" 
#include<cstdio> 
#include<iostream> 
using namespace std; 
#define eps -1e-6 
#define MAX 100005 
struct Point 

    double x,y; 
}; 
struct Line 

    Point a,b; 
    int flag; 
}s[MAX]; 
inline double cross(Point &o,Point &a, Point &b)  //oa*ob  (a.x-o.x,a.y-o.y)*(b.x-o.x,b.y-o.y)  *表示叉積 
{   
    return   (a.x-o.x)*(b.y-o.y)-(a.y-o.y)*(b.x-o.x); 
}  
inline bool quick(Line &p,Line &q) 
{//一個快速排斥,一個跨立,推出線段相交 
    if(min(p.a.x,p.b.x)<=max(q.a.x,q.b.x)&& 
        min(q.a.x,q.b.x)<=max(p.a.x,p.b.x)&& 
        min(p.a.y,p.b.y)<=max(q.a.y,q.b.y)&& 
        min(q.a.y,q.b.y)<=max(p.a.y,p.b.y)&& 
         cross(p.a,q.a,q.b)*cross(p.b,q.a,q.b)<eps&&//驗證p的兩端點是否在q兩端 
         cross(q.a,p.a,p.b)*cross(q.b,p.a,p.b)<eps)//驗證q的兩端點是否在p兩端 
        return true; 
    return false; 

 
int main() 

    int n,i,j; 
    while(scanf("%d",&n),n) 
    { 
        for(i=1;i<=n;i++) 
        { 
            scanf("%lf%lf%lf%lf",&s[i].a.x,&s[i].a.y,&s[i].b.x,&s[i].b.y); 
            s[i].flag=1; 
        } 
        printf("Top sticks:"); 
        for(i=1;i<n;i++) 
        { 
            for(j=i;j<=n;j++) 
                if(quick(s[i],s[j])) break; 
            if(j==n+1) printf(" %d,", i); 
        }    
        printf(" %d.\n",n); 
    } 
    return 0; 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved