程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu1015(Safecracker )

hdu1015(Safecracker )

編輯:C++入門知識

Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST ===
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 = target

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then."

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."

 

Sample Input
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output
LKEBA
YOXUZ
GHOST
no solution


#include<stdio.h>  #include<string.h>  #include<math.h>  int vist[1000],flog,len,target,s[10],top,loction[10];  int m[1000];  int cmp()  {      int v,w,x,y,z;//一定要注意轉換成int型的精度問題      v=s[1];      w=(int)(pow(s[2]*1.0,2.0)+0.5);      x=(int)(pow(s[3]*1.0,3.0)+0.5);      y=(int)(pow(s[4]*1.0,4.0)+0.5);      z=(int)(pow(s[5]*1.0,5.0)+0.5);      if(v-w+x-y+z==target)       return 1;//相等反回1       return 0;  }  void DFS(int n)  {      int i;      s[++top]=m[n];//放數的棧      loction[top]=n;//記綠m[n]的位置      vist[n]=1;//表示第n個位置被訪問了        if(top==5)//相等就可以比較          flog=cmp();      if(flog)//為真,則找到了不用往下          return ;      if(top<5)//只有棧中小於5個數才繼續可以放數      {          for(i=1;i<=len;i++)          if(vist[i]==0)          {              DFS(i);              if(flog)//用來結束上層的DFS              return ;          }      }            vist[n]=0;top--;//退回  }  int main()  {     char str[1000],tem;     int i,j,e;     while(scanf("%d %s",&target,str)>0)     {          if(target==0&&strcmp(str,"END")==0)          break;         flog=0;         len=strlen(str);         for(i=0;i<len;i++)//按字典序從大到小排         {             e=i;             for(j=i+1;j<len;j++)             if(str[e]<str[j])             e=j;             tem=str[i];str[i]=str[e];str[e]=tem;         }         for(i=0;i<len;i++)//變成數字         m[i+1]=str[i]-'A'+1;           for(i=1;i<=len;i++)//以第i個數為開頭         {             memset(vist,0,sizeof(vist));             top=0;             DFS(i);             if(flog)             break;         }         if(flog)         {             for(i=1;i<=top;i++)             printf("%c",str[loction[i]-1]);         }         else         printf("no solution");         printf("\n");     }  }  #include<stdio.h>
#include<string.h>
#include<math.h>
int vist[1000],flog,len,target,s[10],top,loction[10];
int m[1000];
int cmp()
{
    int v,w,x,y,z;//一定要注意轉換成int型的精度問題
    v=s[1];
    w=(int)(pow(s[2]*1.0,2.0)+0.5);
    x=(int)(pow(s[3]*1.0,3.0)+0.5);
    y=(int)(pow(s[4]*1.0,4.0)+0.5);
    z=(int)(pow(s[5]*1.0,5.0)+0.5);
    if(v-w+x-y+z==target)
     return 1;//相等反回1
     return 0;
}
void DFS(int n)
{
    int i;
    s[++top]=m[n];//放數的棧
    loction[top]=n;//記綠m[n]的位置
    vist[n]=1;//表示第n個位置被訪問了

    if(top==5)//相等就可以比較
        flog=cmp();
    if(flog)//為真,則找到了不用往下
        return ;
    if(top<5)//只有棧中小於5個數才繼續可以放數
    {
        for(i=1;i<=len;i++)
        if(vist[i]==0)
        {
            DFS(i);
            if(flog)//用來結束上層的DFS
            return ;
        }
    }
    
    vist[n]=0;top--;//退回
}
int main()
{
   char str[1000],tem;
   int i,j,e;
   while(scanf("%d %s",&target,str)>0)
   {
        if(target==0&&strcmp(str,"END")==0)
        break;
       flog=0;
       len=strlen(str);
       for(i=0;i<len;i++)//按字典序從大到小排
       {
           e=i;
           for(j=i+1;j<len;j++)
           if(str[e]<str[j])
           e=j;
           tem=str[i];str[i]=str[e];str[e]=tem;
       }
       for(i=0;i<len;i++)//變成數字
       m[i+1]=str[i]-'A'+1;

       for(i=1;i<=len;i++)//以第i個數為開頭
       {
           memset(vist,0,sizeof(vist));
           top=0;
           DFS(i);
           if(flog)
           break;
       }
       if(flog)
       {
           for(i=1;i<=top;i++)
           printf("%c",str[loction[i]-1]);
       }
       else
       printf("no solution");
       printf("\n");
   }
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved