程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 10131 - Is Bigger Smarter? (動態規劃)

UVA 10131 - Is Bigger Smarter? (動態規劃)

編輯:C++入門知識

               Is Bigger Smarter?
The Problem
Some people think that the bigger an elephant is, the smarter it is. To disprove this, you want to take the data on a collection of elephants and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the IQ's are decreasing.

The input will consist of data for a bunch of elephants, one elephant per line, terminated by the end-of-file. The data for a particular elephant will consist of a pair of integers: the first representing its size in kilograms and the second representing its IQ in hundredths of IQ points. Both integers are between 1 and 10000. The data will contain information for at most 1000 elephants. Two elephants may have the same weight, the same IQ, or even the same weight and IQ.

Say that the numbers on the i-th data line are W[i] and S[i]. Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing an elephant). If these n integers are a[1], a[2],..., a[n] then it must be the case that

   W[a[1]] < W[a[2]] < ... < W[a[n]]
and
   S[a[1]] > S[a[2]] > ... > S[a[n]]
In order for the answer to be correct, n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and IQs must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7題目分析:要求找出重量從小到大、智商從大到小排列的最長子序列。解題思路:1、對大象按重量從小到大排序。2、從前向後遍歷所有大象,開辟動態滾動數組dp[i]代表當前大象為終點形成的序列長度,dp[j]代表以i之前符合要求的大象為終點的序列長度,如果dp[j]+1>dp[i],則dp[i]=dp[j]+1,用路徑path[i]記下j(i之前那頭大象)。3、輸出最長序列的長度,並遞歸輸出路徑。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct ele
{
	int w,s,id;
}a[1005];
int dp[1005],path[1005],MAX=-1;
bool comp(ele a1,ele a2)
{
	return a1.w<a2.w;
}

/*遞歸輸出路徑*/
void printpath(int i)
{
	if(MAX--)
	{
		printpath(path[i]);
		printf("%d\n",a[i].id);
	}
}

int main()
{
	int i,j,p,k;
	k=1;
	while(~scanf("%d%d",&a[k].w,&a[k].s))
	{
		a[k].id=k;
		k++;
	}
	k--;
	sort(a+1,a+k,comp);
	for(i=1;i<=k;i++)
	{
		dp[i]=1;
		path[i]=i;
	}
	for(i=1;i<=k;i++)
	{
		for(j=1;j<i;j++)
		{
			if(a[i].w>a[j].w&&a[i].s<a[j].s&&dp[i]<dp[j]+1)
			{
				dp[i]=dp[j]+1;
				path[i]=j; /*記錄i之前那頭大象*/
			}
		    if(dp[i]>MAX)
			{
				MAX=dp[i];
				p=i;
			}
		}
	}
	printf("%d\n",MAX);
    printpath(p);
	return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved