程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> zoj 2107 : Quoit Design

zoj 2107 : Quoit Design

編輯:C++入門知識

Quoit Design

--------------------------------------------------------------------------------

Time Limit: 5 Seconds      Memory Limit: 32768 KB

--------------------------------------------------------------------------------

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.


Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.


Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.


Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0


Sample Output

0.71
0.00
0.75

 

 

--------------------------------------------------------------------------------

Author: CHEN, Yue
Source: Zhejiang Provincial Programming Contest 2004


算法:

題目意思:求離散點群中的最小距離點對。

思想:

計算幾何,先用sort()對所有點排序,然後進行暴力遍歷,中間進行優化,定義臨時距離ltemp,若下一個小於ltemp,則更新ltemp,否則退出,因為後面的都不會小於ltemp。

 

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double inf=1e9;
struct node
{
    double x,y;
} Point[100001];
bool cmp(node A,node B)
{
    if(A.x!=B.x)
        return A.x<B.x;
    else
        return A.y<B.y;
}
int main()
{
    int n,i,j;
    double ans,ltemp;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;++i)
        {
            scanf("%lf%lf",&Point[i].x,&Point[i].y);
        }
        sort(Point,Point+n,cmp);
        ans=inf;
        for(i=0;i<n-1;++i)
        {
            ltemp=inf;
            for(j=i+1;j<n;++j)
            {
                double l=(Point[i].x-Point[j].x)*(Point[i].x-Point[j].x)+(Point[i].y-Point[j].y)*(Point[i].y-Point[j].y);
                if(l<ltemp)
                {
                    ltemp=l;
                }
                else
                    break;
            }
            ans=min(ltemp,ans);
        }

        printf("%.2lf\n",sqrt(ans)/2);
    }
    return 0;
}

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved