程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> 關於C++ >> 1028. List Sorting (25)

1028. List Sorting (25)

編輯:關於C++
List Sorting (25)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1

3 1

000007 James 85

000010 Amy 90

000001 Zoe 60

Sample Output 1

000001 Zoe 60

000007 James 85

000010 Amy 90

Sample Input 2

4 2

000007 James 85

000010 Amy 90

000001 Zoe 60

000002 James 98

Sample Output 2

000010 Amy 90

000002 James 98

000007 James 85

000001 Zoe 60

Sample Input 3

4 3

000007 James 85

000010 Amy 90

000001 Zoe 60

000002 James 90

Sample Output 3

000001 Zoe 60

000007 James 85

000002 James 90

000010 Amy 90

#include<stdio.h>
#include<string.h>
typedef struct{
    int id,score;
    char name[10];
}Student;
int cmp1(const void* a,const void* b){
    return (*(Student*)a).id-(*(Student*)b).id;
}
int cmp2(const void* _a,const void* _b){
    Student a=*(Student*)_a;
    Student b=*(Student*)_b;
    if(strcmp(a.name,b.name)) return strcmp(a.name,b.name);
    else return a.id-b.id;
}
int cmp3(const void* _a,const void* _b){
    Student a=*(Student*)_a;
    Student b=*(Student*)_b;
    if(a.score!=b.score) return a.score-b.score;
    else return a.id-b.id;
}
int main()
{
    int N,C;
    scanf("%d %d",&N,&C);
    Student stu[N];
    int i;
    for(i=0;i<N;i++){
        scanf("%d %s %d",&stu[i].id,stu[i].name,&stu[i].score);
    }
    int (*fp)(const void*,const void*);
    if(C==1) fp=cmp1;
    if(C==2) fp=cmp2;
    if(C==3) fp=cmp3;
    qsort(stu,N,sizeof(Student),fp);
//  if(C==1) qsort(stu,N,sizeof(Student),cmp1);
//  if(C==2) qsort(stu,N,sizeof(Student),cmp2);
//  if(C==3) qsort(stu,N,sizeof(Student),cmp3);
    for(i=0;i<N;i++){
        printf("%06d %s %d\n",stu[i].id,stu[i].name,stu[i].score);
    }
    return 0;
}
  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved