程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> UVA 10069 Distinct Subsequences(DP)

UVA 10069 Distinct Subsequences(DP)

編輯:C++入門知識

UVA 10069 Distinct Subsequences(DP)


考慮兩個字符串,我們用dp[i][j]表示字串第到i個和字符串到第j個的總數,因為字串必須連續

因此dp[i][j]可以有dp[i][j-1]和dp[i-1][j-1]遞推而來,而不能由dp[i-1][j]遞推而來。而後者的條件

是字串的第i個和字符串相等。

A subsequence of a given sequence is just the given sequence with some elements (possibly none) left out. Formally, given a sequence X =x1x2xm, another sequence Z = z1z2zk is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of Xsuch that for all j = 1, 2, …, k, we have xij = zj. For example, Z = bcdb is a subsequence of X = abcbdab with corresponding index sequence< 2, 3, 5, 7 >.

In this problem your job is to write a program that counts the number of occurrences of Z in X as a subsequence such that each has a distinct index sequence.

Input

The first line of the input contains an integer N indicating the number of test cases to follow.

The first line of each test case contains a string X, composed entirely of lowercase alphabetic characters and having length no greater than 10,000. The second line contains another string Z having length no greater than 100 and also composed of only lowercase alphabetic characters. Be assured that neither Z nor any prefix or suffix of Z will have more than 10100 distinct occurrences in X as a subsequence.

Output

For each test case in the input output the number of distinct occurrences of Z in X as a subsequence. Output for each input set must be on a separate line.

Sample Input

2
babgbag
bag
rabbbit
rabbit

Sample Output

5
3

import java.io.*;
import java.math.*;
import java.util.*;
public class Main{
	  public static void main(String []args){
		  Scanner cin=new Scanner(System.in);
		  int t=cin.nextInt();
		  while(t--!=0){
			  char a[]=cin.next().toCharArray();
			  char b[]=cin.next().toCharArray();
//			  System.out.println("2333  ");
			  BigInteger [][] dp=new BigInteger[110][10100];
			  for(int i=0;i

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved