程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> [hdu]TOYS 幾何

[hdu]TOYS 幾何

編輯:C++入門知識

TOYS
Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 7   Accepted Submission(s) : 5

Problem Description
Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
 

Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
 

Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
 

Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
 

Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
 

Source
PKU
 

[cpp]
// 765.cpp : 定義控制台應用程序的入口點。 
// 
 
#include "stdafx.h" 
 
 
#include<cstdio> 
#include<cstring> 
#define MAX 5050 
using namespace std; 
int n,m,x1,y1,x2,y2; 
int a[MAX][2],b[MAX],c[2][2]; 
int main() 

    int i,j,x,y; 
    while(scanf("%d",&n),n) 
    { 
        memset(b,0,sizeof(b)); 
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2); 
        for(i=1;i<=n;i++) 
            scanf("%d%d",&a[i][0],&a[i][1]); 
        a[n+1][0]=x2,a[n+1][1]=x2; 
        for(i=1;i<=m;i++) 
        { 
            scanf("%d%d",&x,&y); 
            for(j=1;j<=n+1;j++) 
            { 
                c[0][0]=a[j][0]-a[j][1]; 
                c[0][1]=y1-y2; 
                c[1][0]=x-a[j][1]; 
                c[1][1]=y-y2; 
                if(c[0][0]*c[1][1]-c[0][1]*c[1][0]>0) {b[j-1]++;break;} 
            } 
        } 
        for(i=1;i<=n+1;i++) 
            printf("%d: %d\n",i-1,b[i-1]); 
        puts(""); 
    } 
    return 0; 


  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved