程序師世界是廣大編程愛好者互助、分享、學習的平台,程序師世界有你更精彩!
首頁
編程語言
C語言|JAVA編程
Python編程
網頁編程
ASP編程|PHP編程
JSP編程
數據庫知識
MYSQL數據庫|SqlServer數據庫
Oracle數據庫|DB2數據庫
 程式師世界 >> 編程語言 >> C語言 >> C++ >> C++入門知識 >> hdu3001 &

hdu3001 &

編輯:C++入門知識

Travelling
Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2520    Accepted Submission(s): 735

 

Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 


Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 


Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 


Sample Input
2 1
1 2 100
3 2
1 2 40
2 3 50
3 3
1 2 3
1 3 4
2 3 10


Sample Output
100
90
7
用三進制來進行壯態壓縮,這樣就可以大大減少狀態數,在預處理一下,就可以了,其次,每一個點都要走一次!

#include <iostream>  #include <stdio.h>  using namespace std;  int threenum[11]={1,3,9,27,81,243,729,2187,6561,19683,59049};  #define inf 0x4f4f4f4f  int dp[600000][15],n,m;  int threeevery[600000][15],dis[15][15];  int fmin(int x,int y){if(x<y)return x;return y;}  void makethree()//先預處理,算出所有的值  {      int i,temp,j;      for(i=0;i<threenum[10];i++)//3的11次      {          temp=i;         for(j=0;j<10;j++)         {             threeevery[i][j]=temp%3;             temp=temp/3;         }      }    }  void init()  {      int i,j,s,e,val;      for(i=0;i<threenum[n];i++)      {          for(j=0;j<n;j++)          {              dp[i][j]=inf;          }      }      for(i=0;i<n;i++)          for(j=0;j<n;j++)              {                  dis[i][j]=inf;              }        for(i=0;i<n;i++)      {          dp[threenum[i]][i]=0;//到自已的點初始化為0      }        for(i=0;i<m;i++)      {                scanf("%d%d%d",&s,&e,&val);              s--;e--;//全部從0開  #include <iostream>
#include <stdio.h>
using namespace std;
int threenum[11]={1,3,9,27,81,243,729,2187,6561,19683,59049};
#define inf 0x4f4f4f4f
int dp[600000][15],n,m;
int threeevery[600000][15],dis[15][15];
int fmin(int x,int y){if(x<y)return x;return y;}
void makethree()//先預處理,算出所有的值
{
    int i,temp,j;
    for(i=0;i<threenum[10];i++)//3的11次
    {
        temp=i;
       for(j=0;j<10;j++)
       {
           threeevery[i][j]=temp%3;
           temp=temp/3;
       }
    }

}
void init()
{
    int i,j,s,e,val;
    for(i=0;i<threenum[n];i++)
    {
        for(j=0;j<n;j++)
        {
            dp[i][j]=inf;
        }
    }
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            {
                dis[i][j]=inf;
            }
      for(i=0;i<n;i++)
    {
        dp[threenum[i]][i]=0;//到自已的點初始化為0
    }

    for(i=0;i<m;i++)
    {

            scanf("%d%d%d",&s,&e,&val);
            s--;e--;//全部從0開[html] view plaincopyprint?             if(val<dis[s][e])                  dis[s][e]=dis[e][s]=val;//排除重邊取最小值        }    }  int makedp()  {      int i,j,k,minx;      bool flag;      minx=inf;      for(i=0;i<threenum[n];i++)//對於每一位都要計算      {          flag=true;//標記是否每一個點都已經經過          for(j=0;j<n;j++)          {              if(threeevery[i][j]==0)//是這個點沒有走                  flag=false;              if(dp[i][j]==inf)//沒有走過              {                  continue;              }              for(k=0;k<n;k++)//加入k這個點              {                  if((j==k)||threeevery[i][k]>=2||(dis[j][k]==inf))//自已到自已的地方,經過超過兩次,不相連通去掉                  continue;                  dp[i+threenum[k]][k]=fmin(dp[i+threenum[k]][k],dp[i][j]+dis[j][k]);//從j到k              }            }          if(flag)//滿足條件,對最小值進行更新          {              for(j=0;j<n;j++)              {                  minx=fmin(dp[i][j],minx);              }          }      }      if(minx==inf)      {         minx=-1;      }        printf("%d\n",minx);      return 1;  }  int main()  {      makethree();      while(scanf("%d%d",&n,&m)!=EOF)      {          init();          makedp();      }      return 0;  }               if(val<dis[s][e])
                dis[s][e]=dis[e][s]=val;//排除重邊取最小值

    }

}
int makedp()
{
    int i,j,k,minx;
    bool flag;
    minx=inf;
    for(i=0;i<threenum[n];i++)//對於每一位都要計算
    {
        flag=true;//標記是否每一個點都已經經過
        for(j=0;j<n;j++)
        {
            if(threeevery[i][j]==0)//是這個點沒有走
                flag=false;
            if(dp[i][j]==inf)//沒有走過
            {
                continue;
            }
            for(k=0;k<n;k++)//加入k這個點
            {
                if((j==k)||threeevery[i][k]>=2||(dis[j][k]==inf))//自已到自已的地方,經過超過兩次,不相連通去掉
                continue;
                dp[i+threenum[k]][k]=fmin(dp[i+threenum[k]][k],dp[i][j]+dis[j][k]);//從j到k
            }

        }
        if(flag)//滿足條件,對最小值進行更新
        {
            for(j=0;j<n;j++)
            {
                minx=fmin(dp[i][j],minx);
            }
        }
    }
    if(minx==inf)
    {
       minx=-1;
    }

    printf("%d\n",minx);
    return 1;
}
int main()
{
    makethree();
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        makedp();
    }
    return 0;
}
 

 

  1. 上一頁:
  2. 下一頁:
Copyright © 程式師世界 All Rights Reserved